This server has been deleted from the list and is available only for archival purposes.
chevron_left Back to List


Welcome to our new Minecraft server. We run 1.6.2 and the Pixelmon mod. Optifine is not compatible with this mod. To use our server please follow these very simple instructions.

Step 1. Update to 1.6.2 and install FML/Pixelmon.

Minecraft Pixelmon Mod 1.6.2 - HOW TO INSTALL

Step 2. Add our server's IP to your list.

Step 3. Get Playing!

There are no reviews for this server yet, you can be the first!